Jump to content
Kexa

Запуск Login\Game server

Recommended Posts

Доброго времени суток

Сборка 

 

Проблема заключается в том что запуск в локальном режиме работает хорошо, но когда меняю ip  на свой(беру его с https://2ip.ru/) при запуске Login server ничего не происходит а Game Server выдает ошибку(скрин прилагается) 

NtVadb6YHBs.jpg

Share this post


Link to post
Share on other sites

Зачем создавать новую тему по Fafurion, если обсуждения всего, что связано с этими хрониками ведется непосредственно в уже созданной теме? Я не понимаю этого! Засоряя форум дубликатами тем, и кучу иных тем по одним и тем же хроникам не дает плюсы любому форуму - наоборот вредит!

 

Теперь к проблеме - С какого момента фуфик стал работать на 110 протоколе? У него 166, а 196 и вовсе не работает у мобиуса. Нет пакетки. Далее по проблеме IP - чтобы вывести сборку в сеть, достаточно править всего один файл по пути - E:\L2J_Mobius\build\fafurion\game\config

default-ipconfig.xml

<!-- Externalhost here (Internet IP) or Localhost IP for local test -->
<gameserver address="Тут указываем внешний адрес" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../data/xsd/ipconfig.xsd">

И на этом настройка завершена. Открываем порты 2106, 7777, 9014.

Share this post


Link to post
Share on other sites
8 часов назад, SeriousMax сказал:

Зачем создавать новую тему по Fafurion, если обсуждения всего, что связано с этими хрониками ведется непосредственно в уже созданной теме? Я не понимаю этого! Засоряя форум дубликатами тем, и кучу иных тем по одним и тем же хроникам не дает плюсы любому форуму - наоборот вредит!

 

Теперь к проблеме - С какого момента фуфик стал работать на 110 протоколе? У него 166, а 196 и вовсе не работает у мобиуса. Нет пакетки. Далее по проблеме IP - чтобы вывести сборку в сеть, достаточно править всего один файл по пути - E:\L2J_Mobius\build\fafurion\game\config

default-ipconfig.xml


<!-- Externalhost here (Internet IP) or Localhost IP for local test -->
<gameserver address="Тут указываем внешний адрес" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../data/xsd/ipconfig.xsd">

И на этом настройка завершена. Открываем порты 2106, 7777, 9014.

Прописал ip в файле ipconfig.xml все запустилось без ошибок, но возник вопрос что прописывать в файлах Login/Game server там по прежнему остался ip локальный своего компа,

при запуске игры вечная загрузка после логин пароля, в l2.ini прописывал как внешний так и свой локальный, всё одинаково, проблему с открытием портов не исключаю gJSFSBObd4A.thumb.jpg.23ce51e4dbf9e19187685b712b54e2ed.jpg

Share this post


Link to post
Share on other sites
Posted (edited)

А где я писал в статье, что там вообще надо что либо прописывать кроме имени базы данных и пароля? Может все же будем сначала читать, а потом уже экспериментировать? Для кого я вообще детально все расписываю интересно... Каждый раз все интереснее и интереснее.

Edited by SeriousMax

Share this post


Link to post
Share on other sites
4 часа назад, SeriousMax сказал:

А где я писал в статье, что там вообще надо что либо прописывать кроме имени базы данных и пароля? Может все же будем сначала читать, а потом уже экспериментировать? Для кого я вообще детально все расписываю интересно... Каждый раз все интереснее и интереснее.

Давай без понтов, в статье написано для тех кто знает, а кто научиться хочет не совсем понятно, если есть вопрос ложно по человечески ответить?
так что давай не умничай, а говори по делу, а то как то пустословно

Share this post


Link to post
Share on other sites
5 часов назад, SeriousMax сказал:

А где я писал в статье, что там вообще надо что либо прописывать кроме имени базы данных и пароля? Может все же будем сначала читать, а потом уже экспериментировать? Для кого я вообще детально все расписываю интересно... Каждый раз все интереснее и интереснее.

Проблема остаеться не решенной, указанный внешний ip в файле ipconfig.xml и l2.ini не конектяться(вечная загрузка) а подключение по внутреннему ip работает замечательно

Share this post


Link to post
Share on other sites
Posted (edited)
4 часа назад, Kexa сказал:

Давай без понтов, в статье написано для тех кто знает, а кто научиться хочет не совсем понятно, если есть вопрос ложно по человечески ответить?
так что давай не умничай, а говори по делу, а то как то пустословно

Для тех кто знает?))) Хм... Для тех кто точно знает, в этой инфе не было бы смысла. Тебе элементарно расписали каждый шаг, где и что писать, а ты полез изменять файлы в тех местах, где никто не говорил. Что ты там намудрил это твои проблемы и только! Скачивай по новой и на этот раз вникай, что нужно делать! С другой стороны тебе и не обязан никто объяснять, это уже человек уделяет свое время. Хочешь разобраться - читай внимательно, что написано, а не накатывай тут жалобы по приколу.

Edited by SeriousMax

Share this post


Link to post
Share on other sites
17 минут назад, SeriousMax сказал:

Для тех кто знает?))) Хм... Для тех кто точно знает, в этой инфе не было бы смысла. Тебе элементарно расписали каждый шаг, где и что писать, а ты полез изменять файлы в тех местах, где никто не говорил. Что ты там намудрил это твои проблемы и только! Скачивай по новой и на этот раз вникай, что нужно делать! С другой стороны тебе и не обязан никто объяснять, это уже человек уделяет свое время. Хочешь разобраться - читай внимательно, что написано, а не накатывай тут жалобы по приколу.

Ну да были бы только статьи и советы полезные)

Твои советы не помогли, уже не раз ставил заново чистую сборку и прописывал в разных местах толку 0
скрин с портами я прикладывал думаю дело в них, но вот ты совета дать видимо не можешь, а по всем догадкам в них дело, ибо в чистой сборке в файле ipconfig.xml  указан внешний ip и в игру заходит только под внутренним, если не порты что может быть, сделано по инструкции!

Share this post


Link to post
Share on other sites
В 06.01.2020 в 22:35, Kexa сказал:

в игру заходит только под внутренним

Добрый день, это из-за роутера, если вы подключите кабель напрямую, вас будет пускать и под внешним.

Когда вы запускаете на роутере, люди могут приконектиться а вы нет (если вы пытаетесь зайти с того же ip адреса где находиться сам сервера).

Share this post


Link to post
Share on other sites
В 09.01.2020 в 12:43, VLemon сказал:

Добрый день, это из-за роутера, если вы подключите кабель напрямую, вас будет пускать и под внешним.

Когда вы запускаете на роутере, люди могут приконектиться а вы нет (если вы пытаетесь зайти с того же ip адреса где находиться сам сервера).

Проблема была с провайдером

Спасибо за помощь!

Share this post


Link to post
Share on other sites
В 09.01.2020 в 12:43, VLemon сказал:

Добрый день, это из-за роутера, если вы подключите кабель напрямую, вас будет пускать и под внешним.

Когда вы запускаете на роутере, люди могут приконектиться а вы нет (если вы пытаетесь зайти с того же ip адреса где находиться сам сервера).

 

22 часа назад, Kexa сказал:

Проблема была с провайдером

Спасибо за помощь!

 

У вас провайдер какой?
Вы в роутере порты прописывали?
У вас ip постоянный?
Вы PPoE настраивали?

Share this post


Link to post
Share on other sites

Не пойму к чему были эти вопросы, ты же сама процитировала ответ человека, что проблема решена, не улавливаю логического объяснения! Всеравно, что приготовить мясо в духовке, тебе об этом сказали, а ты пошла его снова готовить... Уже готовое! Ты мне кажется просто для количеств сообщения штампуешь, другого объяснения не вижу.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...